1 - Подготовка к работе

Знакомство с любой программой всегда начинается с ее установки. Чтобы предотвратить возможные проблемы на этом этапе, пожалуйста, внимательно ознакомьтесь с данным разделом.

1.1 - Установка программного комплекса

1.1.1 - Комплект поставки

В фирменной упаковочной коробке Комплекса поставляются:

  • дистрибутив (один или несколько компакт-дисков);
  • руководство (в электронном виде);
  • инструкция по установке (инсталляции) программ, входящих в установочный комплект;
  • регистрационная карточка;
  • лицензионное соглашение;
  • электронный ключ защиты типа USB;
  • рекламно-информационные материалы.

Серийный номер ключа и пароль указаны на регистрационной карточке. При наличии нескольких электронных ключей, пароль и серийный номер указываются для каждого ключа.

По инициативе разработчика комплектация программного комплекса может меняться в зависимости от многих факторов без дополнительного уведомления.

1.1.2 - Процедура установки программного комплекса

Перед установкой Комплекса в сетевом варианте на нескольких компьютерах необходимо проверить и при необходимости изменить следующие настройки компьютера:

  • Имя компьютера, на который устанавливается сервер базы данных, должно состоять из сочетания латинских букв (A-Z, a-z) и цифр;
  • Должен быть установлен сетевой протокол TCP/IP.

Установка Комплекса на компьютер с ОС семейства Windows производится с поставляемого дистрибутива на съемном носителе. Чтобы инсталлировать программу на компьютер, необходимо запустить инсталлятор.

Далее мы рассмотрим пример установки с компакт-диска.

Чтобы инсталлировать программу на компьютер, необходимо вставить компакт-диск в привод CD-ROM или DVD. На экране монитора появится окно автозапуска.

Если по какой-либо причине (обычно из-за настроек компьютера) такое окно не появилось, то нужно зайти в меню ПУСК, выбрать команду Выполнить. В появившейся строке набрать следующую команду *:\СтройОфис\setup.exe, где * означает имя (букву) привода CD-ROM или DVD. После запуска программы установки на экран выводится окно подготовки данных, необходимых для установки Комплекса (см. рис. 1).

Рис. 1. Окно подготовки данных

Для продолжения инсталляции нажмите кнопку Далее> (см. рис. 2).

Рис. 2. Окно приветствия

Обязательно ознакомьтесь с лицензионным договором!

Далее, если Вы с ним согласны, нажмите кнопку Да (см. рис. 3).

Рис. 3. Лицензионный договор

Затем открывается следующее окно, в котором Вы можете указать путь установки программного комплекса (диск и каталог). По умолчанию инсталлятор предлагает произвести установку на локальный диск с наибольшим объемом в каталог StroySoft, в данном случае это каталог D:\StroySoft\ (см. рис. 4).

Рис. 4. Выбор папки назначения

Если необходимо установить Комплекс в другое место, то воспользуйтесь режимом Обзор, вызываемым по одноименной кнопке. Данный режим ничем не отличается от стандартного режима Windows для выбора папки. После выбора папки назначения нажмите кнопку Далее>.

После нажатия кнопки Далее> программа установки перейдет в окно выбора компонентов для установки (см. рис. 5).

Рис. 5. Выбор компонентов

Сервер базы данных – компоненты, отвечающие за хранение и обработку данных (нормативных баз и созданных смет). Устанавливается на сервере (при сетевом варианте установки) или на рабочем месте сметчика (при локальной установке).

Непосредственно Сервер базы данных должен быть установлен однократно, независимо от варианта (сетевого или локального) установки программы.

При установке в сетевом варианте база данных должна быть общей для всех локальных рабочих мест. Поэтому на остальные рабочие места устанавливать Сервер базы данных нет необходимости. В процессе установки на рабочие места, если снята отметка с пункта Сервер базы данных, инсталлятор запросит путь к базе данных, которая, к примеру, находится на сервере (выделенном компьютере). В этом случае необходимо в процессе установки программы на рабочих станциях (локальных рабочих местах) указать путь к каталогу, в котором размещен файл path.txt. По умолчанию он находится в каталоге D:\StroySoft\Server\Base\. Файл содержит строку подключения к базе данных в формате Firebird (см. рис. 6).

Рис. 6. Путь к базе данных

Программа установки осуществит попытку соединения с базой данных и, в случае успеха, добавит строку подключения в файл GDBPath.net, который находится в каталоге D:\StroySoft\Smeta.RU\Client\Data\.

Данный шаг установки не обязателен и может быть пропущен. В этом случае и в случае неудачного подключения к базе данных программой установки, необходимо задать строку подключения, прописав ее в указанный выше файл в следующем формате:

<Имя сервера>: D:\StroySoft\Server\Base\datasd.ssd или <IP-адрес сервера>: D:\StroySoft\Server\Base\datasd.ssd.

ПКSmeta.RU” (см. рис. 5) устанавливается обязательно на каждое рабочее место.

Драйвер локального ключа (см. рис. 5) устанавливается на каждый компьютер (в сетевом или локальном варианте) в обязательном порядке.

Сервер лицензий (см. рис. 5) - сервер, управляющий доступом к Комплексу и к защищенным (лицензированным) нормативным базам, сборникам индексов пересчета, видам цен. Устанавливается только при сетевом варианте либо вместе с Сервером базы данных, либо на отдельный компьютер, но обязательно на тот компьютер, где установлен сетевой ключ HardLock.

Администрирование инсталлятора (см. рис. 5) – необязательный компонент, предназначен для формирования собственных дистрибутивных комплектов.

Клиент мониторинга баз данных (см. рис. 5) - компонент, осуществляющий настройку резервного копирования и восстановления баз данных.

Обозреватель документов в формате DOC (см. рис. 5) – компонент, необходимый для просмотра технических частей к сборникам нормативов. Устанавливается при отсутствии MS Word.

Файлы обновления базы данных (см. рис. 5) - файлы, необходимые для обновления баз данных до текущей версии без инсталлятора

Оставить Firebird 2.5 - СУБД необходимая для работы 10 и ниже версий программы.

При установке Сервера базы данных в следующем окне по нажатию на кнопку Далее инсталлятор предлагает настроить процедуру автоматического резервного копирования базы данных. Выберите приемлемый вариант, обусловленный расписанием штатных процедур резервного копирования и режимом работы компьютера, на котором устанавливается база данных. По умолчанию флажок установлен на пункте Да (рекомендуется) (см. рис. 7).

Рис. 7. Настройка резервирования

Резервирование базы данных необходимо для автоматического создания резервных копий баз данных и автоматического удаления копий, потерявших актуальность. По умолчанию резервирование осуществляется каждый понедельник в 03:00 часа, а копии, которым более 14-ти дней, будут удалены. Если копия в единственном экземпляре, то удаление не производится.

В следующем окне инсталлятор предложит выбрать или создать папку в меню ПУСК для размещения ярлыков устанавливаемой программы (см. рис. 8).

Рис. 8. Выбор папки

По нажатию на кнопку Далее начнется установка выбранных компонентов (см. рис. 9).

Рис. 9. Процесс установки

После установки появляется окно с сообщением о завершении установки, либо окно, в котором инсталлятор предложит перезагрузить компьютер (см. рис. 10).

Рис. 10. Установка завершена

1.1.3 - Процедура удаления программного комплекса

Для деинсталляции Комплекса необходимо воспользоваться приложением Windows Установка и удаление программ (Windows XP) или Программы и компоненты (Windows Vista, Windows 7, Windows 8, Windows 10), находящимся в Панели управления (см. рис. 1).

Рис. 1. Удаление или изменение установки программы

В появившемся окне настроек необходимо выбрать пункт Удалить (см. рис. 2).

Рис. 2. Удаление программного комплекса

По нажатию кнопки Далее программа установки выдаст предупреждение, при утвердительном ответе на которое начнется процесс деинсталляции (см. рис. 3).

Рис. 3. Процесс удаления

После окончания процесса деинсталляции появляется окно с сообщением о завершении операции, либо окно, в котором инсталлятор предложит перезагрузить компьютер (см. рис. 4).

Рис. 4. Установка завершена

1.1.4 - Изменение состава установленных компонентов

Рис. 1. Изменение состава установленных компонентов

Выбрав пункт Изменить (см. рис. 1), можно изменить состав установленных компонентов. После нажатия на кнопку Далее инсталлятор предложит окно выбора компонентов (см. рис. 2).

Рис. 2. Выбор компонентов

При этом показывается перечень установленных компонентов путем отметки флажками. Снятие отметки в этом режиме означает удаление данного компонента, а добавление отметки вызывает дополнительную установку не установленного ранее компонента. Таким образом, если в этом режиме снимается отметка с тех пунктов, что уже инсталлированы, то при работе инсталлятора такие пункты деинсталлируются. Инсталлятор устанавливает только те пункты, которые отмечены флажками, пустые позиции он деинсталлирует.

1.1.5 - Исправление состава установленных компонентов

Клиентская составляющая Комплекса, исполняемый файл, файлы отчетов, плагины и т.д. могут быть исправлены программой установки с сохранением имеющихся СНБ и сметных документов.

Рис. 1. Исправление состава установленных компонентов

После выбора пункта Исправить и нажатия кнопки Далее (см. рис. 1), инсталлятор автоматически исправит все установленные компоненты на том компьютере, на котором проводится исправление.

1.1.6 - Обновление текущей версии комплекса программой установки

Обновление Комплекса при изменении старших номеров версии (например, текущая версия 9.0.Х.Х, новая версия 10.0.Х.Х) производится с применением программы установки.

Для обновления версии Комплекса запустите инсталлятор новой версии.

Если на данном компьютере уже установлен Комплекс предыдущей версии, на экране появится окно (см. рис. 1).

Рис. 1. Изменение, исправление или удаление программы

Для обновления версии выберите пункт Исправить, нажмите Далее и ответьте утвердительно на запрос (см. рис. 2).

Рис. 2. Запрос на обновление

Программа установки автоматически определит наличие установленных компонентов Комплекса и произведет обновление по каждому из них. Обновление может занять существенное время, если на компьютере установлена серверная составляющая. Процесс обновления показан на рис. 3, 4 и 5.

Рис. 3. Обновление серверной составляющей

Рис. 4. Обновление библиотек расширения

Рис. 5. Установка завершена

При обновлении сетевой установки необходимо выполнить обновление каждого клиентского места Комплекса. Если серверная составляющая обновлена, а клиентское место нет, то при подключении к общей базе выдается сообщение вида "Версия базы: A.B.C.D. Версия программы: E.F.G.H. Необходимо установить новую версию программы".

  • В процессе обновления могут возникнуть следующие проблемы:

Программа установки обнаружила заблокированный файл и предлагает варианты дальнейших действий: Перезагрузка, Повтор, Пропустить.

Решение: выберите пункт Перезагрузка.

  • Программа обновления предлагает Вам удалить файлы, которые на данный момент используются (файлы BDE).

Решение: выберите пункт Нет.

  • Программа установки после обновления предложила перезагрузить компьютер.

Решение: для того, чтобы все изменения вступили в силу, рекомендуется перезагрузить компьютер.

1.1.7 - Обновление текущей версии комплекса с помощью патча/релиза

Обновление Комплекса при условии изменения младших номеров версии (например, текущая версия 10.0.0.0, новая версия 10.0.0.2) производится с применением патча или релиза.

Внимание. При обновлении версии с помощью релиза необходимо иметь лицензию на версию релиза.

Для обновления версии Комплекса запустите на исполнение файл PatchStroyOffice.exe с локального диска компьютера.

Внимание. При обновлении создается временная копия файла БД, поэтому на диске должно быть свободное место.

После запуска программы на экран выводится окно с информацией о дополнениях и исправлениях, содержащихся в данном патче/релизе (см. рис. 1).

Рис. 1. Обновление

По нажатию на кнопку Далее программа в автоматическом режиме произведет поиск установленного на компьютере Комплекса. Результат представлен на рис. 2.

Рис. 2. Выбор обновляемых компонентов

Если в автоматическом режиме не удалось найти компоненты Комплекса, то воспользуйтесь режимом Обзор, вызываемым по кнопке с изображением открывающейся папки или по кнопке Добавить базу для обновления. Данный режим совпадает со стандартным режимом Windows для выбора файла.

После выбора файла, программа проверит версию Комплекса и, в случае соответствия, указанного выше, отобразит компоненты Комплекса: исполняемый файл и базы данных, если таких баз было найдено несколько. Базы данных добавляются в список обновления только в том случае, если удовлетворяют следующим условиям:

  • версия базы данных совпадает по старшим номерам с версией патча;
  • в строке подключения к базе данных отсутствует имя компьютера, или присутствует имя локального хоста localhost, или присутствует имя локального компьютера.

В процессе выполнения, программа обновления записывает во временный каталог лог своей работы, а также сохраняет копию каждой обновляемой базы. Для изменения расположения временного каталога необходимо нажать на кнопку Параметры (см. рис. 3).

Рис. 3. Выбор временного каталога

По нажатию на кнопку Обновить начнется процесс обновление (см. рис. 4 и 5).

Рис. 4. Процесс обновления клиентской части

Рис. 5. Процесс обновления базы

Обновление может занять некоторое время, в зависимости от размера файла и количества обновляемых баз данных. Завершив процесс обновления, программа выдаст сообщение и изменит наименование кнопки Отмена на Закрыть.

1.2 - Настройка программного комплекса

1.2.1 - Первый запуск программного комплекса

В момент первого запуска программного комплекса необходимо ввести пароль (см. рис. 1), а также подключить лицензии на программу, нормативные базы, индексы пересчета и виды цен (см. рис. 2).

Рис. 1. Ввод пароля.

Рис. 2. Менеджер лицензий

Для подключения лицензии на программу воспользуйтесь режимом Обзор, вызываемым по кнопке Подключить лицензию. Данный режим совпадает со стандартным режимом Windows для выбора файла. Лицензии на программу, нормативные базы, индексы пересчета и виды цен могут быть размещены как на диске с дистрибутивом, так и на отдельном диске, входящем в комплект поставки.

Файлы лицензий имеют следующие расширения:

  • лицензия на программу: *.slw;
  • лицензия на нормативную базу: *.sln;
  • лицензия на индексы пересчета: *.sli;
  • лицензия на виды цен: *.slz.

Также при первом запуске программы пользователю предлагается включить режим информирования о наличии обновлений - Информер Smeta.RU (см. рис. 3 и п. 14.8).

Рис. 3. Информер Smeta.RU

1.2.2 - Настройки программного интерфейса

Настройки программного интерфейса заключаются в организации вида основных рабочих таблиц (сметных документов) в соответствии с выбранным пользователем перечнем отображаемых полей, их порядка, подбора удобной ширины показа полей и высоты строк, а также наличия, места и размеров вспомогательных окон данных.

Внимание. Далее в руководстве рассмотрены иллюстрации, которые могут незначительно отличаться от вашего интерфейса программы. Важным условием иллюстрации является отображение описываемого функционала в конкретном разделе.

Основные настройки доступны через главное меню программного комплекса Настройки --> Параметры... (см п. 15.1).

Настройки интерфейса индивидуальны для каждого пользователя Комплекса и сохраняются для применения при последующей работе. Однако, осуществив вход в систему под учетной записью Администратор, можно распространить текущие настройки интерфейса на всех зарегистрированных пользователей, а также экспортировать настройки в файл или импортировать их из файла (см. рис. 1).

Рис. 1. Параметры программы

Для настройки интерфейса предназначено контекстное меню, открываемое щелчком правой клавиши мыши на панелях инструментов либо на главном меню. Контекстное меню позволяет отображать и скрывать панели инструментов, а также открывать диалоговое окно (см. рис. 2).

Рис. 2. Настройка

Вкладка Панели инструментов позволяет отображать и скрывать, создавать, удалять и переименовывать панели инструментов, а также производить сброс настроек каждой из них, т.е. отменять все внесенные пользователем изменения.

Вкладка Команды содержит объединенные в группы команды Комплекса, предназначенные для перетаскивания мышью на панели инструментов и в разделы главного меню.

Вкладка Настройки позволяет включить режим отображения больших кнопок, настроить всплывающие подсказки и анимацию меню.

Комплекс позволяет осуществить настройку для окон таблиц смет. Для этого необходимо в открытом окне проектной сметы вызвать контекстное меню, в меню Вид выбрать подменю Настройка вида таблицы... (см. рис. 3).

Рис. 3. Управление отображением столбцами

Кроме того, в окнах работы со сметами допускается отображение вспомогательных окон - панелей с выбором мест их расположения и размеров окон.

Все панели перетаскиваются зажатой левой кнопкой мыши и могут быть «примагничены» к любому краю окна программы. Рекомендуется включить «Поправки», «Индексы», «Строка формул», «Панель цен», «Сметные ресурсы», «Лимитированные затраты», «Структура объекта» и «Выделение строк» и прикрепить их как показано на рис. 4:

Рис. 4. Настройка вида таблицы

Включение режима «Закрепить окна» позволяет зафиксировать все примагниченные окна в том положении, в котором они находятся и защитить их от случайного перетаскивания.

Кроме настроек сметных таблиц, Комплекс позволяет осуществить настройки вида сборников нормативов, в соответствии с определенным пользователем порядком отображаемых полей, подбора удобной ширины показа полей и высоты строк, наличия, места и размеров вспомогательных окон данных, а также сортировки записей сборника по текстовым либо числовым полям или наборам полей. На рис. 5 показан вариант сортировки записей сборника работ по трем полям в порядке следования (возрастания) значений полей.

Рис. 5. Настройка таблицы нормативов

При необходимости определяются размеры и расположение дополнительных панелей связанных данных - окон полного наименования норматива, состава работ нормы (расценки), примененных ресурсов.

Комплекс позволяет настроить контекстные меню таким образом, чтобы группировать часто используемые функции в отдельные пункты подменю, удалять неприменяемые пункты для компактности отображения, изменять порядок пунктов в списке действий, а также задавать "горячие клавиши" для выполнения отдельных функций без вызова контекстного меню (см. п. 15.2).

В программном комплексе предусмотрена возможность изменения масштаба шрифтов (см. п. 15.3), а также возможность увеличения размера иконок, отображаемых на панелях инструментов (см. п. 15.4).

Для общего сброса всех настроек Комплекса необходимо запустить программу с параметром: SmetaRu.exe -sr. Сброс настроек производится только для того пользователя, под именем которого осуществлен вход в Комплекс.

1.2.3 - Администрирование прав пользователей

1.2.3.1 - Пользователи и права

Комплекс обеспечивает многопользовательский доступ к элементам структуры сметных документов и к базам нормативов.

Управление таким доступом реализовано путем администрирования прав пользователей с графическим отображением перечня действий в отношении перечисленных объектов обработки и указанием состава действий, разрешенных конкретному пользователю. Набор допустимых действий (просмотр, изменение, создание, удаление, печать, экспорт) обеспечивает полнофункциональную работу с каждым элементом структуры.

Рекомендуется создавать учетную запись для каждого пользователя, так как большинство настроек Комплекса зависит от введенных при его запуске имени и пароля. Кроме этого, при работе в сетевом режиме невозможен одновременный вход в систему нескольких пользователей под одним именем.

Список пользователей задается администратором (учетная запись Администратор) Комплекса с указанием паролей индивидуального доступа (текстовое значение произвольной длины). Разрешено создание функциональных групп пользователей с распределением пользователей по таким группам с наследованием прав по группе для прав пользователей, включенных в данную группу. Кроме того, администратор имеет возможность индивидуально изменять наследованные права доступа применительно к конкретному пользователю.

Функция администрирования прав доступна через главное меню Комплекса Настройки --> Администрирование --> Пользователи и права (см. рис. 1).

Рис. 1. Настройка прав доступа

Окно прав доступа визуально делится на две части. Левая часть содержит список групп и пользователей, зарегистрированных в системе; правая часть – непосредственно права на выполнение различных действий для пользователя (группы), выбранных в левой части окна.

Комплекс позволяет осуществить настройку прав доступа как на категории прав, так и на конкретные папки и объекты. В последнем случае Комплекс позволит в случае необходимости обеспечить защиту сметной документации для той или иной группы пользователей или конкретных пользователей в группе.

В Комплексе по умолчанию созданы три группы пользователей, в каждой из которых есть один пользователь. Данное разделение условно и представлено в качестве примера.

Права доступа (правая часть окна) делится логически на две части:

  • Общие права доступа (вкладка Права доступа). Это глобальная категория прав, не относящихся к конкретным объектам, а также права по объектам для всех элементов структуры, присутствующих в дереве объектов (см. рис. 1);
  • Права доступа для элементов структуры (вкладка Объекты). Позволяет назначить права пользователю с детализацией до конкретного объекта (папки) (см. рис. 2).

Рис. 2. Настройка прав доступа для элементов структуры

Назначение любых прав на папку ведет к назначению этих прав на все дочерние элементы - папки и объекты. Назначение прав на дочерние элементы идет только в том случае, если на этот элемент не были ранее назначены свои права. Если же они были назначены, то такой элемент становится сам родителем с точки зрения распространения прав и не подчиняется изменению прав своих родителей.

Работа с узлом Объекты аналогична работе с любым узлом-папкой. Существует возможность запретить пользователям работу в корневой папке Объекты, но разрешить в своей личной папке.

Для сброса собственных прав у всех дочерних элементов папки нужно щелкнуть по иконке права доступа правой клавишей мыши и в выпадающем меню выбрать соответствующее действие (см. рис. 3).

Рис. 3. Настройка прав доступа для дочерних элементов узла-папки

Программа запросит подтверждение о действии над всеми дочерними элементами (см. рис. 4) и, после положительного ответа, сбросит у них собственные права.

Рис. 4. Подтверждение действия над элементами

Если на объект (папку) назначены конкретные права, то при проверке прав доступа используются они, в противном случае используются права, назначенные на элемент-родитель (папку, в которую входит проверяемый элемент). Если права не назначены ни на один из родителей проверяемого объекта, то проверка происходит по глобальному праву (заданному на закладке Права доступа).

Права доступа на группу пользователей используются для быстрого назначения прав всем пользователям, входящим в группу. При изменении прав доступа на группе запрашивается подтверждение на распространение прав на всех пользователей группы (см. рис. 5).

Рис. 5. Изменение прав доступа для группы пользователей

При положительном ответе на пользователей группы распространяются все права, заданные на группу. Так же для всех пользователей, добавляемых в конкретную группу, изначально автоматически копируются права доступа с группы пользователей. Кроме того можно скопировать права группы на конкретного пользователя просто потянув мышкой группу к пользователю, при этом будет запрошено подтверждение на назначение прав с группы (см. рис. 6).

Рис. 6. Изменение прав доступа для пользователя

Также можно распространить выделенную в данный момент группу прав с текущего пользователя на всех отмеченных администратором пользователей. Этот режим вызывается нажатием правой кнопки мыши на любом элементе структуры с последующим выбором пункта меню Групповое назначение (см. рис. 7).

Рис. 7. Контекстное меню

В окне Групповое назначение прав (см. рис. 8) сверху показывается элемент структуры, с которого идет распространение прав, и пользователь, с которого возьмется набор прав. Слева перечислены права, справа дерево групп/пользователей. Для распространения прав на группы или на отдельных пользователей следует выставить необходимые галочки в дереве групп/пользователей, после чего нажать на кнопку ОК и подтвердить назначение прав (см. рис. 9).

Рис. 8. Групповое назначение прав

Рис. 9. Подтверждение назначения

Изменение прав пользователей (доступно только для Администратора) возможно либо проставлением галочки в нижней части окна прав доступа, либо нажатием левой кнопки мыши на изображении конкретного действия в колонке Доступные действия (см. рис. 10).

Рис. 10. Изменение прав доступа

Запрещенные пользователю действия отображаются в колонке доступных действий на затемненном фоне, и, соответственно, у них снят переключатель в нижней части окна.

Некоторые действия взаимозависимы, например, при отключении пользователю права на просмотр объекта автоматически для такого пользователя снимаются все остальные права по работе с этим объектом.

Для упрощения работы с объектами в многопользовательском режиме, в секции Менеджера Объекты создана общая папка ОБМЕН (см. рис. 11). Ее назначение - сброс собственных прав элемента, который туда переносится (в отличие от переноса в другую, обычную папку - в этом случае все права на элемент сохраняются). Папка ОБМЕН видна всем пользователям и может быть использована, например, для обмена объектами вместо экспорта-импорта.

Рис. 11. Общая папка Обмен

1.2.3.2 - Пользователи, роли и права

Для упрощения процесса настройки прав пользователей в режиме "Администрирования прав пользователей" существуют роли и области действия. Рабочая область – одна или несколько папок (объектов) в Менеджере объектов, доступных пользователю без каких-либо ограничений. Настраивается для группы и для каждого пользователя в отдельности. Область действия – одна или несколько папок (объектов) в Менеджере объектов, доступных пользователю согласно примененной Роли. Настраивается для каждой Роли. Роль – предопределенный набор прав и Область действий, определяющих привилегии или действия в рамках использования Комплекса. Каждому пользователю может быть назначена Рабочая область (одна или ни одной) и от 0…N Ролей. Только пользователь "Администратор" может назначить пользователю Рабочую область и Роли, предоставляющие определенные права доступа за пределами Рабочей области.

Рис. 1. Роли и права

Вкладка "Пользователи" предназначена для создания групп, пользователей, определения рабочей области и назначения ролей. Вкладка "Роли и права" предназначена для создания ролей, определения областей действия и назначения на области действия тех или иных прав доступа.

1.2.4 - Установка и удаление нормативных баз

Нормативные базы, устанавливаемые в Комплекс, представлены файлами с расширением *.smf и находятся на поставляемых компакт-дисках либо предоставляются другими способами, определяемыми службой технической поддержки.

Для установки или удаления нормативов необходимо обеспечить монопольный доступ к базе данных (только с одного рабочего места) и войти в Комплекс под учетной записью Администратор, в главном меню программы Смета выбрать подменю Установка / удаление нормативов. Далее появится следующее окно (см. рис. 1).

Рис. 1. Установка и удаление нормативов

Чтобы установить необходимую нормативную базу, нужно выбрать пункт Установка нормативов (данный режим совпадает со стандартным режимом Windows для выбора файла) и в открывшемся окне выбрать устанавливаемую нормативную базу (см. рис. 2).

Рис. 2. Выбор файла

После выбора требуемого файла с нормативной базой, отобразится окно с перечнем устанавливаемых нормативов (см. рис. 3).

Рис. 3. Выбор устанавливаемой нормативной базы

Пункт Удалять нормативы, отсутствующие в импортируемом файле необходимо отмечать в тех случаях, когда устанавливается обновленная нормативная база поверх существующей (уже установленной) для того, чтобы удалять нормативы, существующие в ранее установленной базе и отсутствующие в устанавливаемой нормативной базе.

Для удаления нормативных баз необходимо в главном меню программы Смета выбрать подменю Установка / удаление нормативов. В появившемся окне (см. рис. 1) выбрать пункт Удаление нормативов и в открывшемся окне выбрать (отметить) удаляемую нормативную базу (см. рис. 4).

Рис. 4. Выбор удаляемой нормативной базы

В правой части окна показаны вложенные папки выбранного раздела. При отметке какой-либо нормативной базы будут отмечены (и в последующем будут удалены) все папки, входящие в состав отмечаемой нормативной базы.

1.2.5 - Обслуживание базы данных

Очень важным является вопрос обслуживания базы данных. Это связано с тем, что вся пользовательская, нормативная и служебная информация, используемая Комплексом, хранится в одном файле. Поэтому повреждение базы данных приводит к потере всей информации, созданной или измененной пользователями.

Внимание! Для предотвращения потери информации рекомендуется проводить регулярное резервное копирование базы данных.

При наличии резервной копии, возможно восстановление всей информации на момент резервного копирования.

Резервное копирование, восстановление, проверка базы данных и ряд дополнительных функций осуществляются при помощи утилиты Мониторинг баз данных (далее – Утилиты), входящей в стандартный комплект поставки Комплекса (см. рис. 1).

Рис. 1. Выбор компонентов

Утилита представлена двумя приложениями:

  • Сервер – невизуальный функциональный модуль, оформленный в виде сервиса Windows и осуществляющий все работы с базами данных: проверку, создание копии, восстановление из копии, поднятие версии, ремонт, перемещение, выключение сервера после создания копии базы данных.
  • Клиент (конфигуратор) – обычное приложение Windows, осуществляющее визуализацию действий сервера и являющееся рабочим инструментом пользователя.

Установка Утилиты осуществляется инсталлятором и имеет следующие особенности:

  • Серверная часть Утилиты устанавливается вместе с Сервером баз данных. Во время первой инсталляции Комплекса выдается запрос на добавление задания (периодическое, каждую неделю в 03:00:00 понедельника) на проверку базы данных. В случае обновления, при первом запуске сервиса происходит автоматическое преобразование файлов конфигурации в новый формат, после чего старые файлы переименовываются в файлы с расширением *.old.
  • Клиентская часть устанавливается отдельным пунктом в инсталляторе (Клиент мониторинга баз данных). По умолчанию клиент пытается соединиться с сервером на локальном компьютере.

Примечание 1. Для WinXP SP2 и выше инсталлятор создает правило для встроенного брандмауэра. При использовании сторонних брандмауэров, необходимо для сервера прописать правило: протокол TCP/IP, порт 5000.

Примечание 2. В службах Windows сервер можно найти по имени StroySoft IB Backup Service.

Интерфейс клиентской части Утилиты достаточно простой и интуитивно понятный. Ниже описаны ее основные функции и режимы работы.

В левой части окна находится дерево баз данных. Как правило, оно состоит из одной базы, расположение которой было определено при установке Комплекса.

В правой части окна расположены кнопки доступа к наиболее важным функциям Утилиты.

Большинство операций (в частности, проверка, копирование и восстановление базы данных), выполняемых Утилитой, возможны только при отсутствии подключенных к базе пользователей. Список активных пользователей можно получить, выбрав в главном меню программы Информация и подменю Информация о базе данных.

Все действия, описанные далее, производятся с одной (выделенной в дереве) базой данных.

  • Проверка базы данных. Производится проверка физической целостности базы данных. Операция может длиться значительное время, что зависит от размера файла базы данных.
  • Создание копии базы данных. Производится резервное копирование базы данных по указанному пути. Резервная копия занимает приблизительно в 10-15 раз меньше дискового пространства, чем исходная база. Резервные копии предназначены для последующего восстановления. Перечень резервных копий отображается в дереве баз данных.
  • Восстановление базы данных. Производится восстановление базы из резервной копии. Возможно восстановление поверх старой базы или в другой файл.
  • Ремонт базы данных. В процессе ремонта сначала создается копия базы, затем из копии на прежнее место восстанавливается новая база данных.
  • Обновление базы данных. Производится обновление базы данных до новой версии при помощи SQL-скриптов, входящих в состав инсталлятора в виде файла SQL.zip, который размещен в папке *:\СтройОфис\, где "*" означает диска на котором хранится инсталлятор.
  • Создание копии и выключение. Производится создание копии базы данных и последующего автоматического выключения сервера.

Примечание. Пользователь должен обладать правом на выключение компьютера.

Для автоматического резервного копирования базы данных Утилита снабжена Журналом заданий. По умолчанию при установке Комплекса создается одно задание на еженедельное сохранение базы. Можно создавать любое количество как однократных, так и периодических заданий на сохранение или проверку базы данных.

Учитывая существенную продолжительность операции сохранения, рекомендуется назначать ее в ночное время, либо в выходные дни. Назначенные задания отображаются в дереве баз данных.

В момент запуска Утилиты происходит автоматическое подключение к серверу. По умолчанию за сервер принят локальный компьютер (localhost). Пока соединение не установлено, практически все элементы управления недоступны, а в левом нижнем углу в строке статуса показывается, что идет постоянный процесс подключения к серверу (см. рис. 2).

Рис. 2. Отсутствие подключения к серверу

Причинами, по которым подключение к серверу не происходит, могут быть следующие:

  • между компьютерами клиента и сервера нет связи по TCP/IP;
  • компьютер, к которому идет подключение, защищен брандмауэром;
  • на компьютере не установлен или не запущен сервер мониторинга баз данных.

Рекомендуется проверить:

  • наличие на компьютере-сервере установленного и работающего сервиса мониторинга баз данных;
  • настройки каждого брандмауэра, включая встроенный;
  • наличие пинга между клиентским и серверным компьютерами.

Для подключения к произвольному серверу в клиенте необходимо выбрать в главном меню программы База данных подменю Подключиться к серверу... и в появившемся окне выбрать компьютер из списка либо набрать его адрес вручную (см. рис. 3 и 4).

Рис. 3. Подключение к серверу

Рис. 4. Список компьютеров

При наборе в качестве имени компьютера допустимо как DNS-имя, так и IP-адрес.

Для добавления (регистрации) новой базы данных, необходимо в главном меню программы База данных выбрать подменю Добавить в список... или нажать в правой части окна кнопку Добавление базы данных. В появившемся окне параметров (см. рис. 5) необходимо выбрать путь к файлу на компьютере, где находится сервер, а также рабочую папку (см. рис. 6).

Рис. 5. Добавление базы данных

Рис. 6. Выбор файла базы данных

Важно: в окне выбора файлов или папок отображается структура каталогов сервера, а не клиента. Вся работа с базами данных также происходит на сервере.

После нажатия кнопки ОК новая база данных добавится и отобразится в левой части главного окна программы (см. рис. 7).

Рис. 7. Главное окно программы

Утилита позволяет добавить различные типы заданий, обеспечивающих автоматическую работу. Задания разделяются на периодические и разовые, а также на задания на сохранение и задания на проверку.

Для добавления задания необходимо раскрыть соответствующий узел в дереве и нажать кнопку Добавить (см. рис. 8).

Рис. 8. Добавление задания

После выбора необходимых параметров и нажатия кнопки ОК новое задание добавится к списку заданий для соответствующей базы (см. рис. 9).

Рис. 9. Задание на сохранение

Аналогичным образом добавляется задание на проверку. При наступлении времени, определенном в задании, это задание запустится на выполнение, при этом в окне клиента против этого задания начнет мигать стрелка. Разовое задание после выполнения автоматически удалится. Результаты выполнения заданий можно посмотреть в журнале операций.

Кроме выполнения заданий на проверку и сохранение, к автоматической работе относится удаление копий базы данных старше определенного количества дней. При этом одна копия всегда остается, вне зависимости от ее давности.

Утилита позволяет осуществлять различные действия и в ручном режиме. Как отмечалось выше, в правой части окна расположены кнопки доступа к наиболее важным функциям Утилиты. Все действия производятся с одной (выделенной в дереве) базой данных.

Чтобы создать копию базы данных, необходимо нажать на кнопку Создание копии базы данных. В ответ появляется запрос с именем копии БД по умолчанию (см. рис. 10).

Рис. 10. Создание резервной копии

Это имя можно оставить или изменить в диалоге выбора файлов. Имя копии базы данных должно быть уникально, т.е. на момент создания копии файла с таким именем на сервере быть не должно.

По нажатию кнопки ОК начнется процесс создания копии. При этом главное окно программы станет недоступно, за исключением кнопок Прервать... и Закрыть, а также некоторых пунктов меню (см. рис. 11).

Рис. 11. Процесс создания копии базы данных

В процессе выполнения операции отображается окно со служебной информацией (см. рис. 12).

Рис. 12. Лог операции копирования

После создания копии базы появится соответствующее уведомление, главное окно программы вновь станет доступно, а в дереве появится соответствующий узел копии (см. рис. 13).

Рис. 13. Копия базы данных создана

Чтобы восстановить базу данных из какой-либо ее копии, необходимо выбрать соответствующую копию и нажать на кнопку Восстановление базы данных (см. рис. 14).

Рис. 14. Восстановление базы данных

При восстановлении базы данных из копии возможны следующие варианты:

  • На место исходной базы данных – текущий файл (файлы) базы данных заменяются восстановленными из копии;
  • Восстановление новой однофайловой базы данных в произвольном месте на сервере;
  • Восстановление новой многофайловой базы данных в произвольном месте на сервере.

При нажатии на кнопку Старт начинается процесс восстановления базы данных из копии.

Для ремонта поврежденной базы данных необходимо нажать кнопку Ремонт базы данных. В процессе ремонта сначала создается копия базы, затем из копии на прежнее место восстанавливается новая база данных.

При необходимости создания копии базы данных и последующего автоматического выключения сервера нужно нажать кнопку Создание копии и выключение. В появившемся окне нужно ввести имя пользователя и пароль учетной записи с правом на выключение сервера (см. рис. 15).

Рис. 15. Имя и пароль пользователя

В случае наличия этого права у пользователя, имя и пароль которого введены, после создания копии базы данных сервер будет автоматически выключен.

Для удаления регистрации базы данных необходимо выбрать соответствующий корневой узел для данной базы и нажать кнопку Удалить. При этом удаляется только регистрационная информация, сами файлы баз из дисковой памяти не удаляются.

Для удаления копии базы данных необходимо выбрать соответствующий узел копии и нажать кнопку Удалить. При этом удаляется как регистрационная информация (узел в дереве), так и сам файл копии базы данных из дисковой памяти.

Примечание 1. Любое действие на сервере может быть прервано путем нажатия кнопки Прервать, однако это может занять достаточно долгое время.

Примечание 2. Во время выполнения задания клиент может быть закрыт. О результатах выполнения задания можно будет узнать из журнала операций в любое время после его выполнения (при наличии подключения к серверу).